Why i hate Mozilla Firefox 5 as a Hacker?

Recently i have worked with Mozilla Firefox 4 and advanced version 5.  It is annoying me.  The following does not supported by advanced version of Firefox .

  • Internet Download Manager Plugin.  My favorite downloading software is supported by mozilla firefox.  What the hell is it?  But i fix this with Flashgot plugins.  This will support the IDM plugin indirectly. 
  • HackBar : Firefox 4 or 5 doesn’t support the Hackbar. i hope you know about hackbar.
  • Firebug 
  • some other plugins….

Hope this will fixed soon by developing the firefox 5 supported plugins.  until what should i do? just hating the Firefox 5 and using Firefox 3.6 only.